Small improvement.
Make RubikCube and RubikCubeMovement generic and not visible outside of their package.
Many small improvements.
Saving Cube state: done
Progress with saving Cube state
Progress with StateSolving
Improvement for Downloader. Remove as much knowledge from it as possible.
Minor improvement.
Improve the 'Scores' dialog: run less on the UI thread which makes this more responsive.
Beginnings of the 'Solving' state.
Separate the network package; rename RubikSize to RubikObject.
Separate the States (and also Dialogues) into their own package.
Corrections
Major rearrangement of the UI.
Making the Dialogs more consistent.
Adjustment to Static's API.
Movement.
Properly remember size of the Cube.
Further simplifications for object movement.
Further simplifications for object movement - remove from it a reference to the Object altogether.
Simplifications for object movement.
Major restructuring - separate the Manipulated Objects (i.e. at the time being - Cubes of various sizes) and the class holding knowledge how those Objects move ( RubikCubeMovement ) into a separate package; remove all knowledge of Objects and the way they move from the main package.
Also available in: Atom